0
Fork 0
mirror of https://github.com/miekg/dns.git synced 2026-10-23 07:14:24 +00:00
Find a file
dependabot[bot] 2e4905fb03
Bump golang.org/x/net from 0.57.0 to 0.58.0 in the all group (#1731)
Bumps the all group with 1 update: [golang.org/x/net](https://github.com/golang/net).


Updates `golang.org/x/net` from 0.57.0 to 0.58.0
- [Commits](https://github.com/golang/net/compare/v0.57.0...v0.58.0)

---
updated-dependencies:
- dependency-name: golang.org/x/net
  dependency-version: 0.58.0
  dependency-type: direct:production
  update-type: version-update:semver-minor
  dependency-group: all
...

Signed-off-by: dependabot[bot] <support@github.com>
Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
History 2026-09-01 19:35:34 +02:00
.github stringToTTL: error when overflowing uint32 (#1698) 2026-01-09 15:45:40 +01:00
dnsutil Fix typos (#1413) 2023-01-14 08:19:09 +01:00
.codecov.yml Add codecov yaml to not fail the build (#600) 2017-12-06 10:36:23 +00:00
.gitignore gitignore update 2013-10-15 13:22:35 +00:00
acceptfunc.go Remove comment about checking zero bit. (#1491) 2023-11-02 13:34:35 +01:00
acceptfunc_test.go Add a hook to catch invalid messages (#1568) 2024-06-13 17:15:27 +02:00
AUTHORS add AUTHOR file 2014-02-10 17:15:49 +00:00
client.go fix Client xxxTimeout policy (#1700) 2026-01-16 16:17:22 +01:00
client_test.go tests: skip unix socket tests for non *nix OSes (#1443) 2023-06-16 17:57:59 +02:00
clientconfig.go Introduce a generic slice clone function (#1432) 2023-03-12 11:14:24 +01:00
clientconfig_test.go chore: don't use deprecated ioutil package (#1445) 2023-03-19 14:01:37 +01:00
CODEOWNERS Add CODEOWNERS (#1042) 2019-12-09 11:50:19 +00:00
CONTRIBUTORS Correctly set the Source IP to the received Destination IP (#524) 2017-09-29 10:38:26 +01:00
COPYRIGHT Remove all copyright notices 2014-09-11 20:57:37 +01:00
dane.go Improve performance by addressing some low hanging fruit. (#444) 2017-02-02 07:33:49 +00:00
defaults.go IsDomainName: check for escape as last character (#1532) 2024-02-15 13:36:08 +01:00
dns.go Fix Rdlength related parsing bug in RFC3597 records (#1214) 2021-02-01 09:10:38 +01:00
dns_bench_test.go ZoneParser: error on parsing an IPv6 address in an A record (#923) 2019-03-09 09:02:18 +00:00
dns_test.go Improve IsFQDN performance (#1453) 2023-04-27 13:36:03 +02:00
dnssec.go MD5: remove keytag calculation (#1724) 2026-06-22 11:15:14 +02:00
dnssec_keygen.go Use ed25519 from Go standard lib (#1243) 2021-03-16 15:37:10 +01:00
dnssec_keyscan.go Allow use of fs.FS for $INCLUDE and wrap errors (#1526) 2024-01-15 15:40:43 +01:00
dnssec_privkey.go Use ed25519 from Go standard lib (#1243) 2021-03-16 15:37:10 +01:00
dnssec_test.go MD5: remove keytag calculation (#1724) 2026-06-22 11:15:14 +02:00
doc.go Run gofmt -w -s *.go (#1408) 2023-01-05 07:53:57 +01:00
duplicate.go Doc updates (#1075) 2020-02-14 22:47:21 +01:00
duplicate_generate.go Tweaks (#1425) 2023-03-02 18:56:59 +01:00
duplicate_test.go Implement SVCB (#1067) 2020-10-11 09:09:36 +02:00
dyn_test.go Remove all copyright notices 2014-09-11 20:57:37 +01:00
edns.go fix EDNS0 flags and MBZ in String() output (#1693) 2025-12-11 17:10:18 +01:00
edns_test.go Add support for Compact Answers OK flag in EDNS (#1639) 2025-03-12 19:03:33 +01:00
example_test.go Fix examples by using net.JoinHostPort (#1368) 2022-04-15 10:13:08 +02:00
format.go Add checks on data length for A and AAAA records (#919) 2019-03-12 16:31:33 +00:00
format_test.go Add checks on data length for A and AAAA records (#919) 2019-03-12 16:31:33 +00:00
fuzz.go Run gofmt -w -s *.go (#1408) 2023-01-05 07:53:57 +01:00
fuzz_test.go Spelling (#1222) 2021-02-25 17:08:05 +01:00
generate.go Allow use of fs.FS for $INCLUDE and wrap errors (#1526) 2024-01-15 15:40:43 +01:00
generate_test.go chore: don't use deprecated ioutil package (#1445) 2023-03-19 14:01:37 +01:00
go.mod Bump golang.org/x/net from 0.57.0 to 0.58.0 in the all group (#1731) 2026-09-01 19:35:34 +02:00
go.sum Bump golang.org/x/net from 0.57.0 to 0.58.0 in the all group (#1731) 2026-09-01 19:35:34 +02:00
hash.go Add indentityHash for algos that don't need hashing (#1340) 2022-03-12 09:41:21 +01:00
issue_test.go tests: reduce timeouts and iterations (#1175) 2020-10-16 09:10:36 +02:00
labels.go Remove space between NextLabel func and doc comment (#1410) 2023-01-06 08:51:52 +01:00
labels_test.go CanonicalName should casefold non-US-ASCII chars (#1470) 2023-09-12 11:57:40 +02:00
leak_test.go Revert doh (#800) 2018-11-01 20:16:39 +00:00
length_test.go Make the 900 number lower in this test (#1176) 2020-10-16 11:55:29 +02:00
LICENSE Restructure license so Github will recognize it. (#1397) 2022-11-12 12:37:31 +01:00
listen_no_socket_options.go Allow SO_REUSEADDR and SO_REUSEPORT to be set simultaneously (#1623) 2025-01-24 11:27:49 +01:00
listen_socket_options.go Allow SO_REUSEADDR and SO_REUSEPORT to be set simultaneously (#1623) 2025-01-24 11:27:49 +01:00
Makefile.fuzz Add fuzzing framework (#580) 2017-11-23 09:34:31 +00:00
Makefile.release Spelling (#1222) 2021-02-25 17:08:05 +01:00
msg.go Make PackDomainName return error if the root label doesn't fit (#1702) 2026-01-22 09:22:52 +01:00
msg_generate.go Annotate unpack* function errors with where the error happened. (#1590) 2025-07-09 14:08:50 +02:00
msg_helpers.go Avoid using a goto loop in unpackDataOpt (#1505) 2023-11-06 07:26:49 +01:00
msg_helpers_test.go Fix some lint checks by (go) staticcheck ./... (#1442) 2023-03-28 19:35:46 +02:00
msg_test.go Add test for forward compression pointer (#1123) 2020-05-27 08:05:25 +00:00
msg_truncate.go Update Truncate doc with compress behaviour (#1217) 2021-02-10 07:41:26 +01:00
msg_truncate_test.go Fix typos (#1413) 2023-01-14 08:19:09 +01:00
nsecx.go Doc updates (#1075) 2020-02-14 22:47:21 +01:00
nsecx_test.go Add a HashName benchmark 2018-11-29 10:28:29 +10:30
parse_test.go fix(test): Increase RSA key length for sig0 (#1682) 2025-10-10 11:02:42 +02:00
privaterr.go Allow use of fs.FS for $INCLUDE and wrap errors (#1526) 2024-01-15 15:40:43 +01:00
privaterr_test.go refactor: remove ParseZone and parseZone (#1099) 2020-04-28 09:24:18 +02:00
README.md Shorter v2 announcement 2026-03-06 09:30:03 +01:00
reverse.go RFC 8490: Implement DSO type registry 2025-04-20 09:47:15 +02:00
rr_test.go Eliminate lexer goroutines (#792) 2018-10-15 17:42:31 +10:30
sanitize.go Avoid calling RR.Header more than once per RR (#891) 2019-01-04 08:12:32 +00:00
sanitize_test.go Tests updates (#556) 2017-11-08 10:01:19 +00:00
scan.go stringToTTL: error when overflowing uint32 (#1698) 2026-01-09 15:45:40 +01:00
scan_rr.go Add RESINFO rr (#1641) 2025-03-18 12:55:06 +01:00
scan_test.go Return error for empty target (#1627) 2025-04-06 16:41:54 +02:00
serve_mux.go answer queries with no matching handler with RcodeRefused (#1151) 2020-08-20 08:41:45 +02:00
serve_mux_test.go Rework and optimise ServeMux (#754) 2018-09-27 07:48:02 +01:00
server.go MsgInvalidFunc: Make DefaultMsgInvalidFunc a variable. (#1690) 2025-12-11 16:06:29 +01:00
server_test.go Allow SO_REUSEADDR and SO_REUSEPORT to be set simultaneously (#1623) 2025-01-24 11:27:49 +01:00
sig0.go fix: input validation for RRSIG.Verify() (#1618) 2025-01-24 11:33:32 +01:00
sig0_test.go fix(test): Increase RSA key length for sig0 (#1682) 2025-10-10 11:02:42 +02:00
smimea.go Simplify and unify various returns (#893) 2019-01-04 10:19:42 +00:00
svcb.go Error: change a whole bunch error messages' prefix (#1657) 2025-07-09 14:25:16 +02:00
svcb_test.go Add RFC 9540 oblivious services via service binding records (#1567) 2024-06-13 17:49:04 +02:00
tlsa.go Simplify and unify various returns (#893) 2019-01-04 10:19:42 +00:00
tmpdir_darwin_test.go tests: skip unix socket tests for non *nix OSes (#1443) 2023-06-16 17:57:59 +02:00
tmpdir_test.go tests: skip unix socket tests for non *nix OSes (#1443) 2023-06-16 17:57:59 +02:00
tsig.go Make tsigGenerateProvider/TsigVerifyProvider public (#1382) 2022-06-21 10:37:36 +02:00
tsig_test.go Make tsigGenerateProvider/TsigVerifyProvider public (#1382) 2022-06-21 10:37:36 +02:00
types.go RFC 8490: Implement DSO type registry 2025-04-20 09:47:15 +02:00
types_generate.go Avoid using strings.Split (#1501) 2023-11-06 07:23:41 +01:00
types_test.go Updates to LOC type RFC1876 (#1440) 2023-03-18 12:57:18 +01:00
udp.go Avoid sendmsg control messages on darwin (#1643) 2025-03-28 16:07:47 +01:00
udp_no_control.go Avoid sendmsg control messages on darwin (#1643) 2025-03-28 16:07:47 +01:00
udp_test.go Run gofmt -w -s *.go (#1408) 2023-01-05 07:53:57 +01:00
update.go Document how to create RRs without rdata (#1642) 2025-03-19 15:42:15 +01:00
update_test.go Use proper section names when producing dig-like output for UPDATEs (#1479) 2023-09-12 11:44:32 +02:00
version.go Release 1.1.73 2026-08-19 07:07:32 +02:00
version_test.go Doc updates (#1075) 2020-02-14 22:47:21 +01:00
xfr.go Fix logic in xfr ReadMsg + add test (#1649) 2025-04-23 19:55:41 +02:00
xfr_test.go Fix logic in xfr ReadMsg + add test (#1649) 2025-04-23 19:55:41 +02:00
zduplicate.go Add RESINFO rr (#1641) 2025-03-18 12:55:06 +01:00
zmsg.go Fix gogen diff 2026-08-18 21:47:33 +02:00
ztypes.go Add RESINFO rr (#1641) 2025-03-18 12:55:06 +01:00

Build Status Code Coverage Go Report Card

DNS version 2 is now available at https://codeberg.org/miekg/dns. This version should be 2x faster across the board. Further optimizations welcome.

The version here will only see specific fixes and nothing else. At some point this repo will be archived.

Alternative (more granular) approach to a DNS library

Less is more.

Complete and usable DNS library. All Resource Records are supported, including the DNSSEC types. It follows a lean and mean philosophy. If there is stuff you should know as a DNS programmer there isn't a convenience function for it. Server side and client side programming is supported, i.e. you can build servers and resolvers with it.

We try to keep the "master" branch as sane as possible and at the bleeding edge of standards, avoiding breaking changes wherever reasonable. We support the last two versions of Go.

Goals

  • KISS;
  • Fast;
  • Small API. If it's easy to code in Go, don't make a function for it.

Users

A not-so-up-to-date-list-that-may-be-actually-current:

Send pull request if you want to be listed here.

Features

  • UDP/TCP queries, IPv4 and IPv6
  • RFC 1035 zone file parsing ($INCLUDE, $ORIGIN, $TTL and $GENERATE (for all record types) are supported
  • Fast
  • Server side programming (mimicking the net/http package)
  • Client side programming
  • DNSSEC: signing, validating and key generation for DSA, RSA, ECDSA and Ed25519
  • EDNS0, NSID, Cookies
  • AXFR/IXFR
  • TSIG, SIG(0)
  • DNS over TLS (DoT): encrypted connection between client and server over TCP
  • DNS name compression

Have fun!

Miek Gieben - 2010-2012 - miek@miek.nl DNS Authors 2012-

Building

This library uses Go modules and uses semantic versioning. Building is done with the go tool, so the following should work:

go get github.com/miekg/dns
go build github.com/miekg/dns

Examples

A short "how to use the API" is at the beginning of doc.go (this also will show when you call godoc github.com/miekg/dns).

Example programs can be found in the github.com/miekg/exdns repository.

Supported RFCs

all of them

  • 103{4,5} - DNS standard
  • 1183 - ISDN, X25 and other deprecated records
  • 1348 - NSAP record (removed the record)
  • 1982 - Serial Arithmetic
  • 1876 - LOC record
  • 1995 - IXFR
  • 1996 - DNS notify
  • 2136 - DNS Update (dynamic updates)
  • 2181 - RRset definition - there is no RRset type though, just []RR
  • 2537 - RSAMD5 DNS keys
  • 2065 - DNSSEC (updated in later RFCs)
  • 2671 - EDNS record
  • 2782 - SRV record
  • 2845 - TSIG record
  • 2915 - NAPTR record
  • 2929 - DNS IANA Considerations
  • 3110 - RSASHA1 DNS keys
  • 3123 - APL record
  • 3225 - DO bit (DNSSEC OK)
  • 340{1,2,3} - NAPTR record
  • 3445 - Limiting the scope of (DNS)KEY
  • 3596 - AAAA record
  • 3597 - Unknown RRs
  • 4025 - A Method for Storing IPsec Keying Material in DNS
  • 403{3,4,5} - DNSSEC + validation functions
  • 4255 - SSHFP record
  • 4343 - Case insensitivity
  • 4408 - SPF record
  • 4509 - SHA256 Hash in DS
  • 4592 - Wildcards in the DNS
  • 4635 - HMAC SHA TSIG
  • 4701 - DHCID
  • 4892 - id.server
  • 5001 - NSID
  • 5155 - NSEC3 record
  • 5205 - HIP record
  • 5702 - SHA2 in the DNS
  • 5936 - AXFR
  • 5966 - TCP implementation recommendations
  • 6605 - ECDSA
  • 6725 - IANA Registry Update
  • 6742 - ILNP DNS
  • 6840 - Clarifications and Implementation Notes for DNS Security
  • 6844 - CAA record
  • 6891 - EDNS0 update
  • 6895 - DNS IANA considerations
  • 6944 - DNSSEC DNSKEY Algorithm Status
  • 6975 - Algorithm Understanding in DNSSEC
  • 7043 - EUI48/EUI64 records
  • 7314 - DNS (EDNS) EXPIRE Option
  • 7477 - CSYNC RR
  • 7828 - edns-tcp-keepalive EDNS0 Option
  • 7553 - URI record
  • 7858 - DNS over TLS: Initiation and Performance Considerations
  • 7871 - EDNS0 Client Subnet
  • 7873 - Domain Name System (DNS) Cookies
  • 8080 - EdDSA for DNSSEC
  • 8490 - DNS Stateful Operations
  • 8499 - DNS Terminology
  • 8659 - DNS Certification Authority Authorization (CAA) Resource Record
  • 8777 - DNS Reverse IP Automatic Multicast Tunneling (AMT) Discovery
  • 8914 - Extended DNS Errors
  • 8976 - Message Digest for DNS Zones (ZONEMD RR)
  • 9460 - Service Binding and Parameter Specification via the DNS
  • 9461 - Service Binding Mapping for DNS Servers
  • 9462 - Discovery of Designated Resolvers
  • 9460 - SVCB and HTTPS Records
  • 9567 - DNS Error Reporting
  • 9606 - DNS Resolver Information
  • 9660 - DNS Zone Version (ZONEVERSION) Option
  • Draft - Compact Denial of Existence in DNSSEC

Loosely Based Upon